My Digital ContributionPosts RSS Comments RSS

Archive for November, 2011

Gentoo users with RAID10 running Linux kernel 3.1.0 please read

Attention Gentoo RAID10 users running Linux kernel 3.1.0.

There is a serious bug introduced in the 3.1.0 code. The Gentoo Kernel Team advises any of our RAID10 users running 3.1.0 (vanilla or gentoo-sources) to patch their kernel or immediately upgrade to gentoo-sources-3.1.0-r1 which includes the upstream patch to correct the issue.

Upstream considers this a “serious flaw”.

From the original patch submission on LKML:

“Anyone running RAID10 with 3.1 is advised to either apply this patch or revert an earlier kernel as soon as possible. In the mean time, remove any hot spares from an RAID10 array.”

From the patch:

“It would normally be possible to recover the data, but that would need care and is not guaranteed.”

Summary: RAID10 3.1.0 kernel users, please upgrade to gentoo-sources-3.1.0-r1 or patch your kernel manually.

4 responses so far